ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_zone\_rrs, ldns\_zone\_soa - ldns\_zone get content

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rr\_list * ldns\_zone\_rrs(const ldns\_zone \*z);

ldns\_rr * ldns\_zone\_soa(const ldns\_zone \*z);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_zone\_rrs*() Get a list of a zone's content. Note that the SOA isn't included in this list. You need to get the with ldns\_zone\_soa.  
**z**: the zone to read from  
Returns the rrs from this zone

*ldns\_zone\_soa*() Return the soa record of a zone  
**z**: the zone to read from  
Returns the soa record in the zone

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_zone ldns\_zone\_set\_rrs*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_zone_rrs(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
