ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_zone\_set\_rrs, ldns\_zone\_set\_soa - ldns\_zone set content

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

void ldns\_zone\_set\_rrs(ldns\_zone \*z, ldns\_rr\_list \*rrlist);

void ldns\_zone\_set\_soa(ldns\_zone \*z, ldns\_rr \*soa);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_zone\_set\_rrs*() Set the zone's contents  
**z**: the zone to put the new soa in  
**rrlist**: the rrlist to use

*ldns\_zone\_set\_soa*() Set the zone's soa record  
**z**: the zone to put the new soa in  
**soa**: the soa to set

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_zone*, *ldns\_zone\_rrs*, *ldns\_zone\_soa*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_zone_set_soa(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
