ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_zone\_sign, ldns\_zone\_sign\_nsec3 - dnssec sign a zone

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_zone* ldns\_zone\_sign(const ldns\_zone \*zone, ldns\_key\_list \*key\_list);

ldns\_zone* ldns\_zone\_sign\_nsec3(ldns\_zone \*zone, ldns\_key\_list \*key\_list, uint8\_t algorithm, uint8\_t flags, uint16\_t iterations, uint8\_t salt\_length, uint8\_t \*salt);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_zone\_sign*() Signs the zone, and returns a newly allocated signed zone  
**zone**: the zone to sign  
**key\_list**: list of keys to sign with  
Returns signed zone

*ldns\_zone\_sign\_nsec3*() Signs the zone with NSEC3, and returns a newly allocated signed zone  
**zone**: the zone to sign  
**key\_list**: list of keys to sign with  
**algorithm**: the NSEC3 hashing algorithm to use  
**flags**: NSEC3 flags  
**iterations**: the number of NSEC3 hash iterations to use  
**salt\_length**: the length (in octets) of the NSEC3 salt  
**salt**: the NSEC3 salt data  
Returns signed zone

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_zone_sign(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
